Skip to content
See the World Through ScienceA project of ALLATRA
NewsBreaking

U.S. Cyber Agency Says Two PHP Flaws Are Under Attack, Federal Fix Due Oct. 29, 2026

AI & Technology

Republish this story

Our work is licensed under Creative Commons BY-NC 4.0. You may republish this piece for free — with credit to ALLATRA Media and a link to the original, unedited beyond length trims, and not for commercial use.

Read the full license

Cables and amber status lights seen through the perforated mesh door of a server cabinet.
Cabling and status lights behind the perforated door of a server cabinet, the kind of hardware that runs web server software (illustrative)."The data hub Shot of an empty server room" by The Yuri Arcurs Collection, via Freepik, Freepik licence · Freepik-License

The U.S. Cybersecurity and Infrastructure Security Agency added two PHP vulnerabilities to its Known Exploited Vulnerabilities catalog on Oct. 26, 2026, the agency's own determination that both are being used in attacks. Its catalog entries give federal civilian agencies until Oct. 29, 2026, to fix them.

Both flaws are in PHP, the programming language behind a large share of the world's websites. A catalog listing also starts the clock for federal agencies. CISA's Binding Operational Directive 26-04 requires Federal Civilian Executive Branch agencies to move first on listed flaws that sit on publicly exposed systems and would give an attacker total control of them.

The two entries are CVE-2026-109618, listed as a PHP memory corruption vulnerability, and CVE-2026-109619, a stale internal request-state vulnerability. The catalog's description of each says the flaw allows unauthenticated remote code execution, meaning code can be run on a server without logging in. Both entries list known use in ransomware campaigns as unknown.

The flaws themselves, known as php2shell, were disclosed and patched earlier in October 2026. The agency's PHP alert, updated to record the catalog listing, says they affect every PHP installation that serves web requests, including Apache with mod_php, PHP-FPM, php-cgi, FrankenPHP and LiteSpeed. It tells organizations to update to PHP 8.5.12, 8.4.27, 8.3.36 or 8.2.35, and to take offline any system that cannot be updated or that runs PHP 8.1 or earlier.

The directive binds only federal civilian agencies, and it also requires them to check whether attackers had already reached a system before the patch was applied. CISA says it encourages every other organization to prioritize fixing catalog-listed flaws as well.

Sources

Spot an error?

Spot an error?

Report an error

Spotted a mistake on this page? Tell us what's wrong and our editors will take a look.

What kind of problem?

Only if you'd like us to be able to follow up. We won't use it for anything else.

We correct mistakes openly. Select any text to flag it. Fixes are logged under our Corrections Policy.

Report an error

Reporting on

U.S. Cyber Agency Says Two PHP Flaws Are Under Attack, Federal Fix Due Oct. 29, 2026

What kind of problem?

Only if you'd like us to be able to follow up. We won't use it for anything else.

We read every report. Corrections are logged publicly.